Conversion to Dalvik format failed with error 1


Using android on eclipse can be frustating sometimes.You create a new
android project and just cant get it to build, run or clean out the errors
eclipse shows up. Most of all, you can get vague errors like the below.

  • Conversion to Dalvik format failed with error 1
  • Could not *find* HelloAndroid.*apk*
  • Updates (from 0.9.1. to 0.9.5) dont work, vague error there too some
    org.eclipse.something is not linking (google, if you are hearing, just do a
    google search out there find out the issues people are facing). Uninstalls
    dont work.

Did a major google search to figure out how to fix it. Found many that
helped, found many that did not. And I am not alone there.

So this is what worked for me

  • Close all projects
  • Restart Eclipse
  • Uninstall both Android under Help-SoftwareUpdates
  • Restart Eclipse
  • Uncheck all under Help-SoftwareUpdates-AvailableSoftware, except the dl-sslgoogle one, install it
  • Restart Eclipse
  • Create a new project now, same problem eh!! 🙂
  • In the root directory of the project you just created, open the .classpath file. Change it to the following
    <?xml version=”1.0″ encoding=”UTF-8″?>
    <classpath>
     <classpathentry kind=”src” path=”src”/>
     <classpathentry kind=”src” path=”test”/>
     <classpathentry kind=”src” path=”gen”/>
     <classpathentry kind=”output” path=”bin”/>
            <classpathentry kind=”con” path=”com.android.ide.eclipse.adt.ANDROID_FRAMEWORK”/>
    </classpath>
  • Main Menu – Project – Clean
  • Project Explorer – – Right Click – Properties – Android – Check Android 1.5 – Hit Apply (a lot of magic happens
    in the console tab on the project)
  • Project Explorer – – Right Click – Properties – Java Build Path – Libraries – Verify if you see a “Android 1.5”
    and not a “android.jar”.

Summary

The only way to add a “Android 1.5” is to edit the classpath file. Google,you should fix this. It would be nice to know what “Android 1.5” signifies here, a jar, external jar, variable, class folder, external class folder or library(usability issue, think about it, how do I add a Android 1.5 from UI, no way now right). Also it would be nice if the create new android project would fix this automatically.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s